Banana Pi – OwnCloud mit Nginx und SSL einrichten

Voraussetzung ist eine LEMP-Installation, wie sie hier beschrieben ist: Nginx, MySQL und PHP

Diese Anleitung ist zwar für einen Banana Pi geschrieben, sollte aber auch für einen Raspberry Pi oder Beaglebone Black funktionieren.

Schritt 1: Nginx mit SSL einrichten

Dazu das Verzeichnis /etc/ssl/nginx erstellen, in das Verzeichnis wechseln und dort ein selbstsigniertes Zertifikat erstellen.

mkdir /etc/ssl
mkdir /etc/ssl/nginx
cd /etc/ssl/nginx
openssl genrsa -out privkey.pem 2048
openssl req -new -x509 -key privkey.pem -out cacert.pem -days 1095

Schritt 2: Datenbank für Owncloud einrichten
Dafür MySQL in der Konsole starten mit

mysql -u root -p

und dann den Nutzer „user“ mit Passwort „password“ erstellen. Anschließend wird die Datenbank „owncloud“ erstellt und alle Rechte dem Nutzer „user“ übertragen.

CREATE USER 'user'@'localhost' IDENTIFIED BY 'password';
CREATE DATABASE IF NOT EXISTS owncloud;
GRANT ALL PRIVILEGES ON owncloud.* TO 'user'@'localhost' IDENTIFIED BY 'password';

MySQL verlassen mit

quit

Schritt 3: Zusätzliche Pakete installieren
Notwendige Pakete für Owncloud sind:

apt-get install php5-gd php5-json php5-curl php5-intl php5-mcrypt php-xml-parser

Außerdem noch

apt-get install bzip2

Schritt 4: (optional) Documentroot für sichere Seiten einrichten

Dafür erstellen man einen neuen Ordner, je nach Vorliebe, in /srv/ oder /var/. Also /srv/secure oder /var/secure.

Schritt 5: Owncloud laden und installieren

Dazu in das eben erstelle Verzeichnis für geschützte Webseiten wechseln ( also z.B. cd /var/secure ) und das Owncloud-Paket herunter laden mit

wget https://download.owncloud.org/community/owncloud-7.0.3.tar.bz2

Danach das Paket entpacken mit

tar -jxvf owncloud-7.0.3.tar.bz2

Anschließend müssen noch die Rechte für den neu erstellten Ordner gesetzt werden, damit NginX auch schreibrechte auf die Ordner bekommt. Dazu den Befehl

chown -R www-data:www-data /srv/secure
bzw.
chown -R www-data:www-data /var/secure

eingeben.

Schritt 6: php.ini anpassen
PHP ist so konfiguriert, dass nur Dateien mit einer maximalen Größe von 2MB hochgeladen werden dürfen. Das reicht allerdings in den seltensten Fällen aus. Um diesen Wert zu erhöhen, muss die Parameter upload_max_filesize und post_max_size Datei php.ini angepasst werden, zum Beispiel auf 1GB.

nano /etc/php5/fpm/php.ini 
[....]
upload_max_filesize = 1024M
[....]
post_max_size = 1024M

Schritt 7: NginX konfigurieren

Dafür wird ein neuer Serverblock oder virtueller Server definiert, indem man in dem Ordner /etc/nginx/sites-available eine neue Datei, die z.B. ssl-default, erstellt.

nano /etc/nginx/sites-available/ssl-default

Die folgende Konfiguration hat bei mir funktioniert:

upstream php-handler {
    # server 127.0.0.1:9000;
    server unix:/var/run/php5-fpm.sock;
}

server {
	listen 443;
      
	ssl on;
	ssl_certificate /etc/ssl/nginx/cacert.pem;	# path to your cacert.pem
	ssl_certificate_key /etc/ssl/nginx/privkey.pem;	# path to your privkey.pem

	root /srv/secure;

	client_max_body_size 1G; # set max upload size
	fastcgi_buffers 64 4K;

	rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
	rewrite ^/carddav(.*)$ /remote.php/carddav$1 redirect;
	rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;

	index index.php;
	error_page 403 /core/templates/403.php;
	error_page 404 /core/templates/404.php;

	location = /robots.txt {
		allow all;
		log_not_found off;
		access_log off;
	}

    location ~ ^/(data|config|\.ht|db_structure\.xml|README) {
    	deny all;
    }

    location / {
		# The following 2 rules are only needed with webfinger
		rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
		rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;

		rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
		rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;

		rewrite ^(/core/doc/[^\/]+/)$ $1/index.html;

		try_files $uri $uri/ index.php;
    }

    location ~ ^(.+?\.php)(/.*)?$ {
        try_files $1 =404;

        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$1;
        fastcgi_param PATH_INFO $2;
        fastcgi_param HTTPS on;
        fastcgi_pass php-handler;
    }

    # Optional: set long EXPIRES header on static assets
    location ~* ^.+\.(jpg|jpeg|gif|bmp|ico|png|css|js|swf)$ {
        expires 30d;
        # Optional: Don't log access to assets
        access_log off;
    }
}	

Der neue, virtuelle Host wird durch einen symbolischen Link im Ordner /etc/nginx/sites-enabled aktiviert.

ln -s /etc/nginx/sites-available/ssl-default /etc/nginx/sites-enabled

Danach PHP-FPM und NginX neu starten mit

/etc/init.d/php5-fpm restart
/etc/init.d/nginx restart

Jetzt kann man sich unter https://yourIP/owncloud am Server anmelden und die Installation abschließen.

Man kommt auf eine Seite, wo man erstmal ein Administrator-Konto anlegt. Anschließend wählt man den Speicherort für die Dateien aus – voreingestellt ist /var/secure/owncloud/data. Wenn dort ausreichen Platz ist, kann man die Einstellung so übernehmen. Die Warnung, dass dieser Ordner nicht sicher sei, da .htaccess nicht richtig funktioniert, kann man dabei getrost ignorieren, da NginX läuft und der Ordner „data“ in der Konfiguration für Zugriffe gesperrt ist.
Dann werden noch Nutzername, Passwort und der Name der oben erstellten Datenbank eingetragen und das wars.

Owncloud Installation abschließen

Ownclud ist installiert!

45 Gedanken zu “Banana Pi – OwnCloud mit Nginx und SSL einrichten

  1. Danke für die Anleitungen. Beim Abarbeiten der Owncloud-Anleitung habe ich aber 2 kleine Fehler entdeckt:

    1) in Deiner „/etc/nginx/sites-available/ssl-default“ sind die beiden Verweise falsch:

    falsch:
    ssl_certificate /etc/nginx/ssl/cacert.pem;
    ssl_certificate_key /etc/nginx/ssl/privkey.pem;

    richtig:
    ssl_certificate /etc/ssl/nginx/cacert.pem;
    ssl_certificate_key /etc/ssl/nginx/privkey.pem;

    2) beim symb. Link fehlt die Datei ssl-default.

    falsch:
    ln -s /etc/nginx/sites-available /etc/nginx/sites-enabled

    richtig:
    ln -s /etc/nginx/sites-available/ssl-default /etc/nginx/sites-enabled

    Viele Grüße

    Heiner

  2. Hallo,

    irgendwas ist noch nicht ganz rund:
    Ich hab alles nach Anleitung erzeugt. Ich habe das secure unter /var/secure angelegt.
    Ansonsten alle Inhalte übernommen. Die info.php vom nginx geht.
    Ich bekomme immer den 404 Not Found beim Aufruf der owncloud Seite.

    Ich versteh die Zeile in der

    root /srv/secwww;

    nicht ? Sollte die nicht auch nach /var/sewww angepasst werden?

    Gibts da entscheidende Tipps?

    Image habe ich das Bananian1411 drauf..

    • Wenn du Owncloud unter /var/secure angelegt hast, muss die Zeile dann

      root /var/secure

      heißen. Mit dieser Zeile legst du den Default-Ordner fest, in dem NginX bei Anfragen auf Port 443 , also https://…, nachschaut. Entspricht der DocumentRoot-Einstellung beim Apache.

      Eine Anfrage an den Server unter
      https://deinserver.de/owncloud
      wird dann vom Server intern nach
      /var/secure/owncloud
      gemappt.

      Gruß.

  3. Hallo,
    danke für das Tutorial.
    Die Installation hat auch soweit geklappt habe das ganze nur mit ownCloud 8.0.0 gemacht. Nun habe ich das Problem, dass ich keine Apps wie z.B. den Kalender aktivieren kann.
    Fehlermeldung im Log:
    [{„reqId“:“f31ec382707db073e3a850902594f644″,“remoteAddr“:“192.168.178.42″,“app“:“core“,“message“:“Die Applikation enth\u00e4lt keine info.xml Datei“,“level“:3,“time“:“2015-03-01T18:49:52+00:00″},{„reqId“:“f31ec382707db073e3a850902594f644″,“remoteAddr“:“192.168.178.42″,“app“:“PHP“,“message“:“copy(http:\/\/apps.owncloud.com\/CONTENT\/content-files\/168708-contacts.zip): failed to open stream: HTTP request failed! at \/srv\/secure\/owncloud\/lib\/private\/installer.php#244″,“level“:3,“time“:“2015-03-01T18:49:52+00:00″},

    Grüße Moritz

  4. Hallo alle zusammen, ich habe ein Problem, bei der Einrichtung der OWN-Cloud und zwar bei der Erstellung des Zertifikats.
    Nach dem Einrichten der Ordnerstruktur führe ich den Befehl ‚openssl genrsa -out privkey.pem 2048‘ aus.
    Daraufhin bekomme ich den Fehler WARNING: can’t open config file: /usr/lib/ssl/openssl.cnf.
    Jemand eine Ahnung, an was das liegen könnte?

    Viele Grüße und vielen Dank
    Antonio

    • Hey Antonio ..

      Sorry für die späte Antwort.
      Hast du da vielleicht ein paar mehr Infos über Betriebssystem und mehr?
      Wenn, wäre es aber „nur“ ein Warning .. das heißt, er sollte nicht abbrechen oder so sondern mit den Default-Werten durch laufen.

      So kann ich dir jetzt aber leider erst mal nicht weiter helfen ..

      Gruß vom Bjoern

  5. Hallo,
    bei mir lief nginx mit php (geprüft) auf http.
    Dann habe ich die Schritte hier nachvollzogen (Befehle kopiert), das sichere Verzeichnis auf /var/secure eingerichtet und auch die Zeile in der /etc/nginx/sites-available/ssl-default entsprechend angepasst. Will ich nun die Owncloud im Browser aufrufen, dann bekomme ich:
    ———————————
    Diese Webseite ist nicht verfügbar.
    ERR_CONNECTION_REFUSED
    (Der Versuch, eine Verbindung zwischen dem Browser und 192.168.169.36 (IP vom Pi) herzustellen, wurde abgelehnt. Möglicherweise ist die Website inaktiv oder Ihr Netzwerk ist nicht richtig konfiguriert.)
    ——————————————————————

    Kannst Du mir vielleicht mit einem Tipp helfen, wo ich nachschauen oder was ich prüfen kann?

    Vielen Dank

    Lutz

  6. Sorry,
    hat sich schon erledigt. Hatte die eine Schlüsseldatei dummerweise als priv.key.pem statt privkey.pem abgespeichert. nach der Umbenennung funktioniert nun alles.

    Vielen Dank für diese tolle Anleitung!

    Lutz

    • Hey Klaus

      Das könnte 2 Ursachen haben ..
      Entweder hast du owncloud in der Konfig für nginx als documen root eingetragen und owncloud liegt dann vielleicht in 192.168.1.199/owncloud/owncloud
      oder nginx interpretiert noch keine php-Dateien. Dann hast du vielleicht noch einen Fehler in der Konfiguration vom fpm

      Ich hoffe, das hilft weiter

      Gruß Bjoern

  7. mittlerweile geht es…. habe aber ein anderes problem… woltle mal zum testen ne 3gb datei hochladen, habe die uploadgröße auf 5gb gesetzt… er fängt an mitten drin verschwindet die uploadleiste im browser und er lädt es nicht hoch…
    und woher weiß ich wieviel speicheer ich habe?
    hab alles auf die externe festplatte gemacht mit 2tb statt ne sata… aber trotzdem die anleitung befolgt…

    wie dem auch sei warum kann ich nichts hochladen?
    kleinere dateien wie 1,2 gb, 300mb etc… gingen…

    • Hallo Klaus

      Also so aus dem trüben kann ich dir auch nicht sagen, wo es da klemmt – ich hatte bei Owncloud allerdings auch immer Probleme bei sehr großen Dateien.
      Vielleicht bringt dich das Owncloud-Forum da weiter ..

      Gruß Bjoern

  8. Hallo,

    ich habe wie in der ANleitung die Upload größe sowie post_max auf
    1024M gesetz sprich 1gb… aber in owncloud steht jetzt 513mb uploadmgröße…
    wieso?

    • Hey Steve

      Hmm – kann sein, dass du die falsche php.ini erwischt hast. Das System legt manchmal mehrere an. Wenn du Apache nutzt, liegt die für dich relevante php.ini in /etc/php5/apache2, wenn du NginX mit fpm nutzt, liegt die Datei in /etc/php5/fpm ..

      Check das bitte noch mal.

      Gruß Bjoern

    • Hallo Sven ..

      Ich bin mir da jetzt nicht ganz sicher, da ich Owncloud nicht mehr nutze, aber wenn ich mich recht erinnere, hat Ownclod doch eine eigene Update-Funktion .. Damit sollte das doch eigentlich gehen.

      Gruß Bjoern

      • hi björn,

        es kommt aber immer ne fehlermeldung und deshalb kann ich es nicht updaten :(Server error. Please check web server log file for details

        • Jetzt wäre ein Blick in eben diese Log-Datei natürlich hilfreich 😉

          Hast du mal nachgeschaut, ob der Ordner, in dem Owncloud liegt, die richigen Rechte hat?
          Normalerweise ist der Nutzer, dem der Ordner gehört, www-data.
          Du kannst zur Sicherheit mal mit chown -R www-data:www-data /pfad/zu/owncloud die Rechte neu setzen und es nochmal versichen.

          Das könnte das Problem schon lösen …

          • Hey Sven

            Also je nachdem, welchen Webserver du nutzt ( Apache oder NginX ) liegen diese log-Dateien in
            /var/log/apache2/error.log oder
            /var/log/nginx/error.log

            Also logst du dich an besten per Konsole auf deinem Rechner ein und beobachtest mit dem Befehl
            tail -f /var/log/apache2/error.log (falls du den Apache nutzt), welche Ausgaben kommen, während du versuchst, dein Owncloud zu updaten. Dann kannst du genau sehen, welche Fehlermeldungen er dabei wirft.

            Meld dich dann wieder .. 🙂

            Gruß Bjoern

        • Nabend Björn,

          hier die Log-Datei

          2015/10/12 20:02:38 [error] 2615#0: *166 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:04:01 [error] 2613#0: *173 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:08:28 [error] 2613#0: *173 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:09:42 [error] 2613#0: *173 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:16:59 [error] 2613#0: *173 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:25:51 [error] 2613#0: *173 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:34:40 [error] 2616#0: *221 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:37:48 [error] 2616#0: *221 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:42:00 [error] 2616#0: *221 upstream timed out (110: Connection timed out) while sending request to upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/files/ajax/upload.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/files/?dir=%2Fapps“
          2015/10/12 20:50:04 [error] 2614#0: *318 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.178.183, server: , request: „POST /owncloud/index.php/apps/updater/ajax/download.php HTTP/1.1“, upstream: „fastcgi://unix:/var/run/php5-fpm.sock:“, host: „192.168.178.199“, referrer: „https://192.168.178.199/owncloud/index.php/apps/updater/update.php“

          • Hmm .. ja. Wie erwähnt nutze ich selber Owncloud nicht mehr .. ich glaube sogar, wegen unter Anderem genau dieser Fehlermeldungen.
            War alles richtig eingerichtet und irgendwann kamen diese Error-Logs.

            Ich kann dir da leider nicht weiter helfen .. Sorry

            Gruß Bjoern

  9. Hallo,

    habe mein Upload_Max größe auf 5gb und post_max ebenfalls auf 5gb gesetzt…
    nun habe ich mal eine test datei mit ca 1gb hochgealden das geht… größere dateien zumbeispiel 3gb fangen an… aber laden es nicht hoch mitten drin bricht es ab… ohne eine fehlermeldung…

    dachte mir dann gut, lade ich es mer sftp hoch… per sftp habe ich es hochgeladen, aber im owncloud wird es nicht angezeigt… die kleinere datei in einem neuen ordner ebenfalls hochgeladen per sftp und diese wird im owncloud angezeigt…

    woran liegt es, dass es zum beispiel bei 3gb dateien mitten drin abbricht beim upload über owncloud, oder wieso wird es nicht im owncloud angezeigt, wenn ich es über sftp hochladen…

    • Das selbe Problem wie bei Klaus weiter oben — da kann ich dir leider auch nur das Selbe sagen .. ich hatte bei Owncloud auch immer Probleme bei sehr großen Dateien. Wo und was da klemmt, kann ich da nicht sagen – ich hab es damals auch nicht heraus finden können.

      Vielleicht bringt in dem Fall wirklich das Owncloud-Forum weiter, denn das Problem ist bekannt.

      Gruß Bjoern

  10. Hallo,

    ich habe mal ne andere Frage, aktuell mache ich abends den owncloud server bzw den banana pi immer aus… Morgens wenn ich es wieder anmache, ist der owncloud server nicht erreichbar, da anscheinend nginx nicht startet…

    auch wenn ich den Befehl „service nginx start“ gebe kommt eine Fehlermeldung

    „Starting nginx: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)“…

    ich muss dann immer wieder erst den pc hochfahren im terminal dann
    diesen Befehl eingeben „fuser -k 80/tcp“
    und dann den nginx neustarten… danach geht es…

    was muss ich machen, damit der immer automatisch wirklich auch startet….

  11. Hallo,
    ich habe ein Problem beim letzten Schritt.
    Wenn ich im Webbroser das Konfigurationsmenü von Owncloud starte, mein Administratorname und Passwort für Owncloud eingebe und abschicke kommt folgende Fehlermeldung:

    „Das Datenverzeichnis /var/secure/owncloud/data kann nicht erstellt oder es kann darin nicht geschrieben werden. “

    Wenn ich nun bei Datenbank-Benutzer und Passwort meinen Benutzer eingebe (Kevin) und das entsprechende Passwort, sowie Datenbank-Name Owncloud dann kommt ebenfalls die gleiche Meldung.

    Habe ich irgendwas falsch gemacht bei der installation oder gar vergessen?
    Ich möchte das Betriebssystem auf der SD Karte lassen, aber dann später die Dateien auf der Festplatte, daher habe ich vorher noch nicht alles auf die Festplatte geschoben…

    • Hey Kevin

      Das klingt nach einem Problem mit den Rechten. Der Nutzer www-data, unter dem der Webserver und somit in dem Fall auch PHP laufen, braucht Schreibrechte auf den Ordner /var/secure/owncloud/data.
      Ich nehme an, du hast Ownclod als nutzer root installiert und vergessen, die Rechte neu zu setzen.

      Das kannst du mit dem Befehl

      chown -R www-data:www-data  /var/secure/owncloud/
      

      chown = change owner

      Damit sollte das Problem dann eigentlich behoben sein.

      Gruß vom Bjoern

      • Danke Bjoern, das hat funktioniert.

        Könnte mir noch jemand schnell erklären wie ich jetzt Owncloud auf die Festplatte zugreifen lasse, bzw Owncloud sage, dass die Dateien nur auf die Festplatte gespeichert werden?

        Ich möchte nur das Betriebssystem und die Programme auf der SD Karte haben…

        Die Festplatte ist schon eingebunden unter: /mnt/nas

  12. so ich habe es Dank google und einer gefundenen Anleitung hinbekommen. Alle Daten liegen nun auf der Festplatte bzw. werden nur dort abgespeichert.
    Hier der Link zur Anleitung (Englisch): https://forum.owncloud.org/viewtopic.php?f=17&t=7118

    jetzt kommt bei mir aber in ownCloud noch folgende Fehlermeldung unter Administration:


    PHP scheint zur Abfrage von Systemumgebungsvariablen nicht richtig eingerichtet zu sein. Der Test mit getenv („PATH“) liefert nur eine leere Antwort zurück.
    Bitte schau in der Installationsdokumentation ↗auf Hinweise zur PHP-Konfiguration, sowie die PHP-Konfiguration Deines Servers, insbesondere dann, wenn Du PHP-FPM einsetzt.“

  13. Hallo Bjoern,

    On linux i am a nobody, I am traying to make a bananapi cloud server but;
    1) Every time i try to create a Owncloud on a finished LEMP 15.04 i am on hold at Step 2:
    mysql -u root -p
    Enter password:
    ERROR 1045 (28000): Access denied for user ‚root’@’localhost‘ (using password: NO)
    Whatever password I tray iam not getting further.

    2) Every time i try to create a Seafile-server on a finished LEMP 15.04 i am not comming past

    /home/xxx/seafile-server-latest/seahub.sh start

    no file or directory maybe you are forgotten saefile-server start

    I am copying every command but nothings gone work at my place.
    Can you give me a hint, I undersand German as wel.

    Pieter

    • Heyho Pieter

      Sorry for the late answer .. I had some .. technical Problems! 🙂 See next Post
      #1) Okay .. The root-password for MySql is set during installation! It has NOTHING to do with your root account on that computer. If you are in doubt, what password you had, just reinstall MySQL again .. if you can afford.

      For the second part I unfortunately need a little bit more info.
      Maybe you contact me again .. from now on I have more time than the last days.

      Cheers Bjoern

  14. For this line ->
    openssl req -new -key -x509 privkey.pem -out cacert.pem -days 1095

    an error appeared -> unknown option privkey.pem

    Change it to ->
    openssl req -new -x509 -key privkey.pem -out cacert.pem -days 1095

    In case of somebody found the same error

Schreibe einen Kommentar